Have you found a bug or issue with Uncharted 4?

"Connection to the store center failed" - Lost Relics!

I lost 2000 relics because I wanted to buy and then came the above mentioned message.

The relics were still charged to me although the purchase was not successful!

What a nuisance! Please give me my relics back!

10 votes
Sign in Sign in with Naughty Dog
Signed in as (Sign out)

We’ll send you updates on this idea

mikhom shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in Sign in with Naughty Dog
Signed in as (Sign out)
  • KingJorge23 commented  ·   ·  Flag as inappropriate

    Hi I tied to purchase some uncharted points and was charged but I never received my uncharted points my psn account is Kingjorge23

  • imicca commented  ·   ·  Flag as inappropriate

    I have same problem.
    1 unopened vanity chest and cannot open it: error- unable to connect to store server
    Have a look at my PSN account: imicca

  • MepH-66 commented  ·   ·  Flag as inappropriate

    Just noticed I got the relics back! Thanks a lot @Naughty Dog QA Team

    You guys are the best !

  • withnail69 commented  ·   ·  Flag as inappropriate

    150 relics lost in the 'replace your challenge' glitch when unable to initialise server. Please credit me ND PSN = withnail69

  • Patchy272 commented  ·   ·  Flag as inappropriate

    Same for me with 2000 relics! Before the issue occurred sometimes when I was replacing a challenge, but that's only 50 relics I can live with that. But 2000 lost relics really is a bother! I aussumed you've implemented a proper transaction system for the shop, since some people (including myself) also put in real money. I won't purchase any Uncharted points until this issue is resolved.

  • withnail69 commented  ·   ·  Flag as inappropriate

    Hello. Yesterday I tried to spend 50 relics to change my challenge and it said something like "unable to initialise server" I lost 150 relics and couldn't change challenges psn = withnail69

  • NGHTWNG__ commented  ·   ·  Flag as inappropriate

    This game needs to be fixed asap! It won't give me relics from completing challenge, then it reset my profile. It says Connecting on relics/uncharted points

  • MepH-66 commented  ·   ·  Flag as inappropriate

    Hello, same problem for me; tried to open a 2000relics chest and didn't got anything and got the same error message; at first I could go back to the store and try to Open that chest again without using more relics, but got the same error message again and again and again.
    Played one command match and now it's 2000 relics again if I want to open a chest, but I still didn't get anything...
    I also didn't receive the 20 relics at the end of the match, but it's ok it's 20 relics! I just hope I can get those 2000 relics back as it is one week worth of playing w/ challenges.

  • alex_300888 commented  ·   ·  Flag as inappropriate

    :( same here, use 2000 relics and fail to get chest, at first I can try to re-open the chest but I try may times still no luck, then after one TDmatch and I can't even re-open it... I think there's a update on store, hopefully QA can return my relics back

  • nacromiles commented  ·   ·  Flag as inappropriate

    Tried to change out a challenged 3 or 4 times. Each time I was given a "failed to connect to the servers", wasn't able to swap out the challenge & my relic points were gone. This also has happened on several occasions if I choose to use a booster but the match that I'm in ends abruptly or kicks me back to the MP loading screen. In those instances, I loose my 1 use booster & i didn't even get a chance to use it or even score relic points to compensate for it by completing the the match. I've seen a couple of post in relation to these, but they wouldn't let me "vote" on them & they also show that they are "solved". The way I see it, I am out about 250 or more relic points. All this isn't a huge deal, I feel that relic points are nearly worthless now, but it is annoying to loose what has been earned.

Feedback and Knowledge Base