Have you found a bug or issue with Uncharted 4?

Error: Failed to connect to the store server - Vanity Chest Glitch

I encountered a glitched where I can't open the standard vanity chests. It says "please wait" for about a minute and then gives the "error: Failed to connect to the store server. "
Here's a link:
Hope this can get fixed!

333 votes
Sign in
Signed in as (Sign out)

We’ll send you updates on this idea

Billenmans shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
fixed  ·  AdminNaughty Dog QA Team (Admin, Naughty Dog) responded  · 

This issue has been resolved with the 1.20 Patch. If you attempted to purchase a Vanity Chest and encountered the error, the Vanity Chest should now be accessible.

We apologize for the inconvenience and thank you for helping us track down the problem. If you continue to encounter the issue after installing Patch 1.20, please post your details in the comments. Thank you.


Sign in
Signed in as (Sign out)
  • Blind0Player commented  ·   ·  Flag as inappropriate

    I completed the challenge from 23/05, on 24/05 and I didn't get my 450points (purple ones), I am absolutely sure because my total after "reviving" it was 100. I hope, as respect to your players, someone could solve that.

  • PandaGangYo commented  ·   ·  Flag as inappropriate

    Sweet i got 400 relic to open a sick hero weapon chest. Expecting to get an actual long gun but instead i get a fucking pistole which I'M NEVER GOING TO USE IT TAKES 4 LP. why are there pistols even in the chest?!?!?! 400 relic is a lot of relic just to WASTE on a WORTHLESS pistol. this is complete bullshit like seriously what a scam smh this game is terrible. I hate naughty dog

  • tekkenlover1 commented  ·   ·  Flag as inappropriate

    Same thing happened to me. I was playing multiplayer and completed a challenge awarding something like 420 relic points, then an error occured and the game closed down. When I went back into the game, I was shown to have -1 relic points and -1 coin points.
    It's really quite off putting as in total I would have had 590 relic points to spend on treasure chests and now I have nothing. Please fix this issue so that the relic and points are returned, I worked very hard to earn them and this sour experience has left me feeling like I don't really want to play MP anymore.

  • rn666rodrigues commented  ·   ·  Flag as inappropriate

    Ive receive my chalenge and i changed in two first choices ocorres an error and no change and not lose any relic in the third moment i got a change and spend 150 of my relics. I need some answer please

  • lucasssotero commented  ·   ·  Flag as inappropriate

    2 weeks.
    LAN with manual dns and mtu.

    after a few matches, i went to the shop to spend that purple coin, bought a chest, it took a bit too long, so i closed the game by pushing the ps button and closing the app. when i opened the multiplayer again, both purple and yellow coins went to -1, and the shop don't load anymore, and popup an ps4's messenge saying that the item can't be purchased anymore, or something like that.

  • herbalverbage commented  ·   ·  Flag as inappropriate

    This happened to me as well. I completed a daily challenge that was to get 10 down with the aegis 9mm and it would've rewarded me with 320 relics. It glitches the same way and I had -1 relics and -1 uncharted points. It's now back to normal but my relics weren't given to me either!

  • zUbermensch commented  ·   ·  Flag as inappropriate

    I was playing Trials, and I completed both the moderate and hard levels of the C4 Trial, and was awarded NO POINTS. Not only that but after leaving my private match and disconnecting from multiplayer, and reconnecting, in order to see if the glitch would correct itself, the 20 points and 200 coins I had DISSAPEARED. I'm now left with -1 OF EACH!!!! Please fix this. This is an unacceptable glitch in the game and seeing as how the assets awarded in the game depend upon these points I must otherwise purchase, I am extremely, extremely dissapointed. Please fix this issue. I would be grateful to find the points erased from my account were restored.

  • shamy_14 commented  ·   ·  Flag as inappropriate

    Did a el dorado challenge which I was supposed to get 450 relics for after I completed it the game started glitching and was showing -1 relics after resetting couple of times it went back to normal but the 450 were not added!

  • FuzzyJD01 commented  ·   ·  Flag as inappropriate

    So I had unlocked my first hero weapons, and since bought several hero weapon chests and had been using them in multiplayer matches, specifically Elena's FAL, however, today when I signed in, all of the hero weapons I had not unlocked via kills, aka the ones from chests, we're locked once again, and thus unusable. Additionally, all of my currencies, the relics(the purple one) and uncharted points(the gold one) were at negative 1. This is pretty weird and I am wondering if this is a known bug, and if I will be able to get back my weapons?


  • MikeEy1991 commented  ·   ·  Flag as inappropriate

    I completed today's challenge, 3 matches of plunder.. I did it and I didn't get my 250 relics! My PSN is Mikeey1991

  • Bloodninjuh commented  ·   ·  Flag as inappropriate

    The same exact thing just happened to me. That C4 challenge is just beyond so I tried to replace it. I had 55 Relics, and used 50 to replace it, except it didn't replace it at all. Instead, it said unable to connect, which is a lie, since my Internet was working fine. So at that point I'm down to 5 Relics, which is annoying, considering how rare they are to begin with. I close the game, reload, and now I'm at -1 Relics. What the hell is this? I just wasted my time playing your broken multiplayer, Naughty Dog? I have a video as well.

  • esemichuy09 commented  ·   ·  Flag as inappropriate

    I am also having this same issue. Come on naughty dog I spend countless hours getting 350 downs with Mazur LDR to unlock drakes hero gun and saved up enough relics for 4 hero chest and now I can't even use those relics..... Fix this ASAP!!!

  • Digitate commented  ·   ·  Flag as inappropriate

    I have unlocked my first hero weapon and I still cannot purchase hero weapon chests.... PSN: Digitate

  • JordanGM96 commented  ·   ·  Flag as inappropriate

    Yesterday I was getting the relics, today I can't anymore. Just stopped accounting the match rewards to me...

  • XxD1xieNormus commented  ·   ·  Flag as inappropriate

    I've been playing plenty of games online and I still haven't been getting any relics towards my customization?

1 2 15 16 17 19 Next →

Feedback and Knowledge Base