Have you found a bug or issue with Uncharted 4?

Error: Failed to connect to the store server - Vanity Chest Glitch

I encountered a glitched where I can't open the standard vanity chests. It says "please wait" for about a minute and then gives the "error: Failed to connect to the store server. "
Here's a link:
Hope this can get fixed!

333 votes
Sign in
Signed in as (Sign out)

We’ll send you updates on this idea

Billenmans shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
fixed  ·  AdminNaughty Dog QA Team (Admin, Naughty Dog) responded  · 

This issue has been resolved with the 1.20 Patch. If you attempted to purchase a Vanity Chest and encountered the error, the Vanity Chest should now be accessible.

We apologize for the inconvenience and thank you for helping us track down the problem. If you continue to encounter the issue after installing Patch 1.20, please post your details in the comments. Thank you.


Sign in
Signed in as (Sign out)
  • Rhazengan commented  ·   ·  Flag as inappropriate

    Please help, same problem ! 3 Vanity chest left and I cannot open it. Gives error cannot connect to store server.
    PSN ID: Rhazengan
    Disc version
    A lot of empty space
    Latest update

  • youngwind_1989 commented  ·   ·  Flag as inappropriate

    Yeah, I also have the same issue. This is so annoying. I already have so many relics saved, yet no fix for that yet. Every day I keep checking every few hours. Please, Naughty Dog, get this stuff fixed. :(

  • ECK304 commented  ·   ·  Flag as inappropriate

    I understand that within the last week, we had Christmas and New Years. Christmas would most definitely be the time to make sure all aspects of your game are working, due to all the people who received this game as a gift. I'd be upset myself if I just received a $60+ game and it wasn't fully functional. All who purchased these crates should be refunded their relics and given a free vanity crate.

  • Jeremy12318 commented  ·   ·  Flag as inappropriate

    It's now 2017 still no fix? NaughtyDog I don't wanna rush you but can you guys please get this fixed?

  • pepenstark commented  ·   ·  Flag as inappropriate

    Still the same problem OMG ... Im at the limit of 10k relics and cant buy Nothing....

  • Blue-Mercenary commented  ·   ·  Flag as inappropriate

    I seem to be having the same problem as everyone else here. It's been glitched for about a week now where I can't open my vanity chests. It just loads for about a minute until
    It says failed to connect to store server although I can access other chests.

  • holdthat230 commented  ·   ·  Flag as inappropriate

    I also am experiencing the same issue. It shows I have two vanity chest that are available for me to open. When I click on the chest, an error messages appear station that it cannot access the store.

  • abc_702 commented  ·   ·  Flag as inappropriate

    I have had a vanity chest for two days that won't let me open it. "Cannot connect to server" after it hour glasses for 45 seconds. So I tried buying one with uncharted points. And now that one is the same as the regular one. Stuck.
    And another thriving issue I've noticed, is why is there a trade KO on the melee grab/stomp on hanging kills? I've noticed it a lot since the update, and if that's the way to equal a button smash at the same time I would think the stomper should win that battle.
    Well thank you for time and hope we can at least fix my vanity chest problem.

  • sachin9960 commented  ·   ·  Flag as inappropriate

    Same issue. I've even wasted points opening it but its the same. Psn is same as the id.

  • SayerBijou commented  ·   ·  Flag as inappropriate

    i have the same problem, but it says (1) cause i purchased it so that means i don't own all items yet does it?

  • BabyKitty2007 commented  ·   ·  Flag as inappropriate

    Same here. Bought with both relics and coins. Says I have (2) and (1) to open but won't let me

  • magedg01 commented  ·   ·  Flag as inappropriate

    I am almost done with buying all the vanity items but now whenever I try to buy the chest, it says "Error: failed to connect to the store server." I've tried buying the other chests and they work just fine.

  • Evofischer commented  ·   ·  Flag as inappropriate

    Good evening!
    I'm having difficulty accessing the store in uncharted 4's multiplayer error when I try to open 1 assorted chest.
    Error: Failed to connect to store server this in bau of assorted.
    Email to contact: evertonfischer@hotmail.com

Feedback and Knowledge Base